Remora v1.4



  • @Fabien-Saragosa non pas essayé, mais c'est vrai que c'est dommage, car si ton Wemos est HS, tu vas devoir t'amuser à tout désouder.

    J'ai 2 petites questions :

    • De peu, j'ai la led qui clignote en bleue, tout le semble fonctionner correctement, mais je n'avais pas ce phénomène en debut de semaine et impossible de trouver une information sur le forum ?
    • Le site "aufilelec" étant HS et je voulais brancher mon relais pour mon ballon d'eau chaude dessus, et voulant être sûr de mes branchements, je veux pas faire de bêtise. Si je veux bien faire, je prendre le fils alimentant mon contacteur (A1) pour le brancher sur le port COM de REMORA, et je ressors du NF vers le contacteur en A1. Enfin j'enlève les fils qui relie mon contacteur à mon module qui gère mon téléinfo de base. J'espère avoir été assez clair dans mes explications.


  • Salut @weado

    La LED de couleur bleu signale soit la réception de trames RFM ou bien lors du rafraîchissement du display si la télé-info n'est pas activée.
    Mon site est de nouveau UP ;-)
    Pour le raccordement de ton ballon d'eau chaude, tu trouveras un schéma de raccordement sur mon site.
    J'ai rapidement testé la version v1.5, mais sans succès. Je n'ai pas cherché pourquoi cela ne fonctionnait pas. Il faudrait que je m'y penche.

    Salut @Fabien-Saragosa
    Je te déconseille de souder directement le Wemos au PCB. Comme le dit @weado, si tu dois remplacer le Wemos, tu vas galérer.



  • @AuFilElec Merci beaucoup pour tes réponses. Par contre, petite question, qu'est-ce que les trames RFM ?



  • @weado
    Les trames RFM correspondent à la communication radio, à l'aide des modules RFM69/RFM12.
    Sur la Remora, il est possible d'ajouter un module radio RFM69 ou RFM12. Ce que je compte utiliser pour faire communiquer les sondes avec la Remora, pour une gestion de chauffage par zone. J'ai créé un ticket sur ce projet.



  • Bonjour,
    Je me lance dans remora pour domotiser mes chauffages électriques.
    J'ai commandé des PCB de la version 1.5 sur PCBs.io, pas certain que ce soit une bonne idée en voyant le dernier message de @AuFilElec.

    Je vous tiendrais au courant des tests des que je reçois les PCB et composants.
    Si tout fonctionne j'aurais 3 PCB dispo.



  • @AuFilElec Merci pour l'information. Je pense que j'ai un soucis alors, c'est que je n'ai pas de moduleRFM69/RFM12... Mais j'ai bien ma diode RGB qui clignote (type un stroboscope) en permanence, mais mon Remora fonctionne correctement. De plus je n'ai pas de display pour le moment, donc cela ne correspond pas.
    Est-il possible d'avoir la désignation pour les autres couleurs (fixe, clignotant, ...) afin de voir si je me suis pas trompé de "sens", même si cela m'étonnerait ?

    @math19 Tiens nous au courant effectivement.



  • J'avance doucement mais surement sur mon Remora. Celui-ci fonctionne maintenant correctement, après avoir cramé un Wemos. Vous trouverez quelques astuces si nécessaire :

    • Le mot de passe OTA, que l'on trouve dans le fichier "remora.h" , n'est pas pris en compte. Celui qui est valable se retrouve sur l'interface Web ou dans le fichier "config.h"
    • Dans mon installation, je me retrouve avec mon affichage OLED qui est à l'envers... (embêtant me diriez vous...). Voici l'astuce pour le changer de sens.
      Dans le fichier "display.cpp" il faut rajouter la ligne "display.setRotation(2);" comme si dessous :

    ...
    void display_splash(void)
    {
    display.clearDisplay() ;
    display.setRotation(2);
    display.setTextColor(WHITE);
    ...

    • Changement d'états des fils pilotes au (re)démarrage :

    Dans le fichier "pilotes.cpp" modifier la valeur de la ligne suivantes :
    // buffer contenant la commande à passer à setFP
    char cmd[] = "xH" ;
    en
    // buffer contenant la commande à passer à setFP
    char cmd[] = "xA" ;

    Par contre, je reste preneur des informations concernant la LED RGB, à savoir à quoi correspond les couleurs disponible et comment la désactiver si nécessaire ?

    Merci



  • Salut @weado

    Tu trouveras les codes couleur de la LED RGB sur mon dépôt Github.
    Oui, le mot de passe OTA est celui du fichier config.h ou celui en mémoire, si vous l'avez modifié sur l'interface Web.
    Pour la rotation de l'afficheur, il serait intéressant de pouvoir la modifier sur l'interface Web.
    Idem pour l'ordre par défaut au démarrage de la Remora.



  • @weado : De plus je n'ai pas de display pour le moment, donc cela ne correspond pas.

    Que tu es un afficheur ou non ne change rien, si le module de l'afficheur est activé, c'est suffisant. Voir le code (https://github.com/hallard/remora_soft/blob/master/display.cpp#L213)



  • Je suis enfin arrivé a me libérer un peu de temps pour monter ma remora en version 1.5 avec une carte lolin d1 mini pro.
    Tout semble fonctionnelle : Ecran OLED ok, Teleinfo ok, mais par contre je n'arrive pas a contrôler mes radiateurs pour l'instant et je n'ai pas encore testé la partie lié au chauffe eau.
    Concernant le contrôle des radiateurs , les consignes arrivent correctement aux triac ( TLP268J, nouvelle version du TLP168). Avez-vous une technique pour tester ce que se passe sur la partie haute tension ? je suis pas serein d'aller mettre mon multimetre bas de gamme dans mon compteur électrique...

    Je soupçonne mon installation de fils pilote, ça sera ma prochaine action

    PS : Petite question, pourquoi avoir, au niveau des triacs, d'un coté l'alim en 5v et de l'autre la sortie du MCP23017 en 3.3V ? si la consigne est faux , je mesure 3.4V sur la résistance 390ohm soit 8.7mA suffisant pour déclencher le triac, mais si consigne est vrai , il y a encore un peu de tension sur la résistance, je mesure 0.38V soit un intensité de 1mA. le datasheet n'est pas très clair si ça déclenche ou non le triac.

    @AuFilElec quel est ton problème avec la V1.5 ?

    En tout cas, super boulot , la partie soft fait vraiment pro ...



  • Salut @math19

    Félicitation pour ta Remora v1.5, pour ma part, elle ne démarrait pas, peut être une mauvaise soudure ou un Wemos défaillant.

    Avec les TLP268J, ils doivent être alimentés en 3.3V et pas en 5V. Tu peux le faire avec le jumper qui se trouve à l'arrière de la carte. C'est peut être pour ça que tu n'arrives pas à contrôler tes radiateurs. Voici le post qui parle des optos en 3.3V.



  • @math19 said in Remora v1.4:

    Concernant le contrôle des radiateurs , les consignes arrivent correctement aux triac ( TLP268J, nouvelle version du TLP168). Avez-vous une technique pour tester ce que se passe sur la partie haute tension ? je suis pas serein d'aller mettre mon multimetre bas de gamme dans mon compteur électrique...

    Si je ne dis pas de connerie, tu dois simplement pouvoir mesurer la résistance (dans les deux sens) en sortie des triacs. Mais effectivement, c'est probablement un souci de 5V vs 3.3V (je me suis fait avoir aussi).



  • @marc
    Pour tester la partie haute tension, il faut vérifier la tension (AC), en fonction des ordres envoyés, entre le neutre et la/les sorties de triacs. Il y a un opto par demi alternance, soit une alternance complète avec les 2 optos activés.

    Attention, la partie haute tension est en 230V AC, risque mortel.

    Sinon, tu peux aussi vérifier que les ordres sont bien appliqués en testant la continuité en sortie des optos, toujours en fonction des ordres envoyés.

    • Confort: Pas de continuité sur les 2 optos
    • ECO: Continuité sur les 2 optos
    • HG: Continuité sur l'opto de la face avant du PCB
    • Arrêt: Continuité sur l'opto de la face arrière du PCB

    Ne pas oublier de déconnecter la phase pour effectuer les tests de continuité.



  • Bonjour,
    J'ai aussi enfin pris un peu de temps et je viens de mettre en service ma Remora en PCB 1.5 avec un Lolin D1 mini (v3.1)
    Pas de grosse difficulté, une fois passé en 3,3v pour les optos (des TLP268J) et l'activation de l'inversion du pilotage du relais (relais que j'aurais d'ailleurs préféré en NF plutôt que NO)
    Je n'ai que la LED multicolore qui ne s'allume pas, mais bon, je ne m'en servirais pas.
    Une remarque concernant la compilation : j'ai dû activer le "MOD_OLED" sinon ça ne passe pas.
    Coté intégration domotique je suis avec Jeedom et le plugin l'a reconnu immédiatement, donc pas de soucis non plus de ce coté là.

    Et comme l'a dit @math19 super boulot, aussi bien sur la partie électronique que sur le soft.



  • Merci à @math19 et @gus pour leur retour sur la version v1.5.

    J'ai repris ma version v1.5 et ajouter un Wemos d1 mini pro, avec le code de la branche master et ça à l'air de fonctionner correctement.

    @gus, pour avoir le contact NF au lieu de NO, sur le relais, tu commentes la variable #RELAIS_REVERSE dans le fichier remora.h.

    Le problème de compilation remonté par @gus, nécessitant l'activation du module OLED, a été réglé sur la branche master.

    Encore merci pour vos retours et vos félicitations, ça fait plaisir.

    Manuel



  • @AuFilElec : c'est vraiment au niveau du relais que je parlais du NF pour le cas où la Remora serait arrêtée (et ne plus avoir d'eau chaude en rentrant à la maison).
    Sinon je vais tester la nouvelle version 1.4.0 du soft, la compilation passe bien désormais sans l'option MOD_OLED. Je vais en profiter pour tester l'OTA en même temps.



  • Salut @gus

    Je pense qu'il est préférable de choisir un contact NO, cela permettra de ne pas avoir de surprise désagréable en recevant ta facture d'électricité, comme certain de mes clients.
    Si la Remora s'arrête et redémarre, elle repassera automatiquement dans le mode qui convient, en fonction de la téléinfo reçue.
    Tu peux utiliser l'URL suivante (http://ip_du_remora/uptime) pour tester que ta Remora est toujours active. Sinon, tu peux utiliser le shield Battery de Wemos, pour servir d'onduleur.

    Manuel



  • Salut @AuFilElec

    J'ai découvert ton projet aujourd'hui, cela fait plusieurs jours que je me tâte sur comment je vais gérer mes fils pilotes.
    Bravo la carte est vraiment top. J'avais un soucis de place dans mon boitier, ça résoud mon problème.

    Pour les présentations je suis un bon geek programmeur autodidacte. J'ai commencé avec les arduinos il y a presque 10 ans maintenant, pour finir par développer sur un peu tout et n'importe quoi, languages compris.

    J'ai vu ton appel de manque d'aide coté dev, je peux filer un coup de main. D'ailleurs j'ai jeté un oeil vite fait sur le git, c'est très clair ( à part les cascades de #ifdef que j’exècre mais je comprends, ça termine toujours comme ça quand on veut faire du multi plateforme avec les microcontrôleurs. )

    As tu un pcb disponible? J'ai regardé par Oshark, mais si tu veux des petites unités ca fait mal et je suis pas au tap de mes finances.
    Quel est le prix total des composants à peu près ?

    Sinon je mettrais bien dessus un ESP32 pour être tranquille coté mémoire ( et parcequ'on est en 2019 :) )
    J'ai quelques modules esp32 dev 1 qui ont la meme empreinte que les nodemcu.

    Je voudrais ajouter le MQTT que j'utilise déjà avec d'autres appareils) et pourquoi pas utiliser le bluetooth ble plutôt que le wifi pour les échanges avec Jeedom ( si le réseau tombe, la box pourra toujours communiquer avec remora ).

    A+



  • Salut @KipK

    Merci, mais le projet est de Thibault Ducret et Charles-Henri Hallard. Je tente de maintenir ce projet en vie, car je trouve que c'est un bon outil.

    Ton aide ne serait pas de trop et je te remercie de proposer de participer. Comme tu pourras le constater, sur le dépôt du projet Remora, il y a déjà @Jon qui propose de nouvelles fonctionnalités très intéressantes, comme le MQTT, les ordres confort -1 et -2, ainsi que la gestion du Linky en version historique.

    Pour les PCB, je t'ai déjà répondu par mail.

    Pour les #ifdef, je les trouve très pratique, même si, il est vrai, il faut les utiliser avec parcimonie et éviter les imbrications.

    Je pense que le bluetooth n'est pas forcément une très bonne idée, pour les échanges avec une box domotique, car la box n'est pas toujours à portée du tableau. Et la portée du réseau bluetooth est limitée. Je pense qu'il serait plus intéressant de l'utiliser pour la configuration de la Remora, lors de la première utilisation. Merci à @Charles pour cette idée. Mais cela nécessite de créer une application sur Android, et Apple, pour les échanges.

    Pour l'ESP32, il est possible d'utiliser le TTGO ESP32 qui a la même empreinte que le Wemos d1 mini.

    A bientôt,
    Manuel