Remora v1.4



  • Bonjour à tous,
    Utilisateur de la remora de sa première version ( dans le groupe des beta testeurs avec une quinzaine d'autres), je pense que cette dernière vient de me lâcher, car impossible de la faire communiquer avec mon wifi, sachant que je passe par Spark, difficile de contrôler le Remora directement.
    C'est la raison pour laquelle je compte changer de version pour passer à la 1.4 (si c'est bien la dernière).

    @AuFilElec : j'ai cru comprendre que tu avais d'autre priorité en ce moment et un manque de soutien. Je pense que les personnes de visite sont très intéressé par le sujet, mais difficile pour eux de rassembler toutes les informations (PCB, composants, code ...). Je te propose de faire un tuto complet, de t'en part pour diffusion, puis d'en faire faire la pub, sur ton site, mais aussi dans le communauté Jeedom (Fervent utilisateur de la solution) et trouver une autre personne côté Domoticz. Qu'en penses-tu ?
    J'espère pouvoir faire cela rapidement avant le grand froid.
    @Marc : Je serais intéressé par un PCB avec des adapteurs Wemos si possible. Si tu peux m'envoyer tes infos par MP ?
    Bonne journée.



  • Salut @weado

    Il existe déjà un tuto pour l'assemblage de la Remora réalisé par Thibault.

    Ce que je trouve dommage, c'est qu'il y a beaucoup de monde à utiliser la Remora, mais personne pour aider à l'évolution du projet. Si personne ne fait évoluer le projet, il va finir par mourir.

    Enfin, je te remercie pour ta proposition.



  • @weado
    Bonjour,
    Mon Remora en 1.2 réalisé en 2016 m'a lâché il y a quelques jours, mon sparkcore ne veut plus communiquer en wifi non plus...
    Du coup, comme je suis en 1.2, je me suis orienté vers une migration avec Adaptateur WeMos + D1 mini Pro. J'avais posté ici il y a quelques jours à la recherche d'adaptateurs dispo.

    Du coup, j'en ai commandé 3 sur OSH si ça t'intéresse. Par contre, j'ai pas de PCB en 1.4 comme tu l'auras compris.
    Bonne journée.



  • @matteo2712
    C'est marrant, mais j'ai exactement le même problème que toi ... c'est bizarre, Particle (Ex Spark) n'y serait pas pour quelque chose ? Est-ce que nous sommes les seuls dans ce cas là ?
    [edit] : Le wifi de mon Spark est bien mort, j'ai tenté plein de chose, mais rien à faire. My remora is dead ! Dans l'attente du 1.4 ;-)



  • @matteo2712 Merci, mais c'est vrai que je vais attendre de trouver un PCB en 1.4, histoire d'être un peu up-to-date ;-)
    Mais si je n'en trouve pas, je te tiens au courant. Merci



  • Est-ce que quelqu'un a testé la Remora avec le PCB sans adaptateur (avec Wemos sur headers) ?



  • @matteo2712 said in Remora v1.4:

    Du coup, comme je suis en 1.2, je me suis orienté vers une migration avec Adaptateur WeMos + D1 mini Pro.

    Attention, chez moi, avec un WeMos (enfin, LOLIN) D1 mini Pro et la version 1.4 du PCB, ça ne tient pas dans la boîte (de justesse) — du moins avec des connecteurs, je pense que ça passerait avec l'adaptateur soudé à la carte et le WeMos soudé à l'adaptateur. Par ailleurs, le bord du WeMos touche le relais.

    Est-ce qu'il y aurait un inconvénient à déplacer le relais et le WeMos vers le bord de la carte, en utilisant la place libérée par le passage d'un relais électromécanique à un relais statique ? Je crois que ça suffirait à pouvoir mettre un D1 mini Pro confortablement.



  • Salut @marc

    Pour ma part, j'ai le PCB v1.4 et un Wemos D1 mini pro et ça passe très bien au niveau du boîtier rail DIN et du relais.
    Quel boîtier as tu ?



  • @aufilelec
    Ce boîtier, je crois : https://fr.farnell.com/multicomp/mc001143/boite-dinrail-module-abs-pc-gris/dp/2544974

    Mais vérification faite, il y a apparemment une petite différence de longueur entre l'ancienne carte WeMos D1 mini Pro et la LoLin D1 mini Pro qui l'a remplacée. Donc ma suggestion d'amélioration tient toujours, mais n'est nécessaire qu'avec la nouvelle version.



  • Certains ont-ils déjà tester la version avec un Wemos en direct, c'est à dire la version 1.5 ?



  • Bonjour,
    n'est-il pas possible de souder le weemos directement sur la carte ?



  • @Fabien-Saragosa non pas essayé, mais c'est vrai que c'est dommage, car si ton Wemos est HS, tu vas devoir t'amuser à tout désouder.

    J'ai 2 petites questions :

    • De peu, j'ai la led qui clignote en bleue, tout le semble fonctionner correctement, mais je n'avais pas ce phénomène en debut de semaine et impossible de trouver une information sur le forum ?
    • Le site "aufilelec" étant HS et je voulais brancher mon relais pour mon ballon d'eau chaude dessus, et voulant être sûr de mes branchements, je veux pas faire de bêtise. Si je veux bien faire, je prendre le fils alimentant mon contacteur (A1) pour le brancher sur le port COM de REMORA, et je ressors du NF vers le contacteur en A1. Enfin j'enlève les fils qui relie mon contacteur à mon module qui gère mon téléinfo de base. J'espère avoir été assez clair dans mes explications.


  • Salut @weado

    La LED de couleur bleu signale soit la réception de trames RFM ou bien lors du rafraîchissement du display si la télé-info n'est pas activée.
    Mon site est de nouveau UP ;-)
    Pour le raccordement de ton ballon d'eau chaude, tu trouveras un schéma de raccordement sur mon site.
    J'ai rapidement testé la version v1.5, mais sans succès. Je n'ai pas cherché pourquoi cela ne fonctionnait pas. Il faudrait que je m'y penche.

    Salut @Fabien-Saragosa
    Je te déconseille de souder directement le Wemos au PCB. Comme le dit @weado, si tu dois remplacer le Wemos, tu vas galérer.



  • @AuFilElec Merci beaucoup pour tes réponses. Par contre, petite question, qu'est-ce que les trames RFM ?



  • @weado
    Les trames RFM correspondent à la communication radio, à l'aide des modules RFM69/RFM12.
    Sur la Remora, il est possible d'ajouter un module radio RFM69 ou RFM12. Ce que je compte utiliser pour faire communiquer les sondes avec la Remora, pour une gestion de chauffage par zone. J'ai créé un ticket sur ce projet.



  • Bonjour,
    Je me lance dans remora pour domotiser mes chauffages électriques.
    J'ai commandé des PCB de la version 1.5 sur PCBs.io, pas certain que ce soit une bonne idée en voyant le dernier message de @AuFilElec.

    Je vous tiendrais au courant des tests des que je reçois les PCB et composants.
    Si tout fonctionne j'aurais 3 PCB dispo.



  • @AuFilElec Merci pour l'information. Je pense que j'ai un soucis alors, c'est que je n'ai pas de moduleRFM69/RFM12... Mais j'ai bien ma diode RGB qui clignote (type un stroboscope) en permanence, mais mon Remora fonctionne correctement. De plus je n'ai pas de display pour le moment, donc cela ne correspond pas.
    Est-il possible d'avoir la désignation pour les autres couleurs (fixe, clignotant, ...) afin de voir si je me suis pas trompé de "sens", même si cela m'étonnerait ?

    @math19 Tiens nous au courant effectivement.



  • J'avance doucement mais surement sur mon Remora. Celui-ci fonctionne maintenant correctement, après avoir cramé un Wemos. Vous trouverez quelques astuces si nécessaire :

    • Le mot de passe OTA, que l'on trouve dans le fichier "remora.h" , n'est pas pris en compte. Celui qui est valable se retrouve sur l'interface Web ou dans le fichier "config.h"
    • Dans mon installation, je me retrouve avec mon affichage OLED qui est à l'envers... (embêtant me diriez vous...). Voici l'astuce pour le changer de sens.
      Dans le fichier "display.cpp" il faut rajouter la ligne "display.setRotation(2);" comme si dessous :

    ...
    void display_splash(void)
    {
    display.clearDisplay() ;
    display.setRotation(2);
    display.setTextColor(WHITE);
    ...

    • Changement d'états des fils pilotes au (re)démarrage :

    Dans le fichier "pilotes.cpp" modifier la valeur de la ligne suivantes :
    // buffer contenant la commande à passer à setFP
    char cmd[] = "xH" ;
    en
    // buffer contenant la commande à passer à setFP
    char cmd[] = "xA" ;

    Par contre, je reste preneur des informations concernant la LED RGB, à savoir à quoi correspond les couleurs disponible et comment la désactiver si nécessaire ?

    Merci



  • Salut @weado

    Tu trouveras les codes couleur de la LED RGB sur mon dépôt Github.
    Oui, le mot de passe OTA est celui du fichier config.h ou celui en mémoire, si vous l'avez modifié sur l'interface Web.
    Pour la rotation de l'afficheur, il serait intéressant de pouvoir la modifier sur l'interface Web.
    Idem pour l'ordre par défaut au démarrage de la Remora.



  • @weado : De plus je n'ai pas de display pour le moment, donc cela ne correspond pas.

    Que tu es un afficheur ou non ne change rien, si le module de l'afficheur est activé, c'est suffisant. Voir le code (https://github.com/hallard/remora_soft/blob/master/display.cpp#L213)