Nouvelle version du Dongle µTeleinfo



  • Bonjour, j'ai depuis hier mon linky et ai branché le dongle micro téléinfo dessus via un cable rj45, je n'ai aucune sortie sous rapsbian . J'ai fait le test avec le dongle sous windows avec les bon drivers, pareil aucune sortie
    J'ai mis un câblage plus court au cas ou mais pareil, rien sous windows ou raspbian.
    Précision, la led verte est bien allumé, mais aucune activité de la led rouge.
    J'ai appelé ERDF qui m'indique que par defaut, le teleinfo est activé en mode historique....
    De plus en théorie, je suis sensé avoir au moins l'identifiant compteur il me semble....
    Mon dongle serait'il HS ?

    pi@cerbere:~ $ lsusb
    Bus 001 Device 007: ID 0403:6015 Future Technology Devices International, Ltd Bridge(I2C/SPI/UART/FIFO)
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    pi@cerbere:~ $ cat /dev/ttyUSB0



  • Le dongle ne fonctionne pas sur linky



  • Bonjour
    Deux dongles commandés, reçus en moins de trois jours.
    Ils ont marché du premier coup sur un rPI 3.
    Fonctionnement parfait avec un premier compteur à 30cm, et le second à 5 m.
    Merci Charles pour la qualité des boards, et le code en C. J'ai pu écrire très rapidement un module adapté à ma domotique : les relevés sont envoyés sur le réseau au format xPL.


  • Staff

    @David,
    Merci pour le commentaire, c'est toujours agréable d'avoir un retour d'utilisateur satisfaits.
    Te serait-il possible de partager ton code pour le XPL, ça m’intéresse aussi et je n'ai jamais pris le temps de m'y pencher ;-)
    Pour information les dongles envoyés depuis 3 mois fonctionnent parfaitement sur Linky, il y avait effectivement un problème détecté par @thevinz et @osegouin et réglé par le changement d'une résistance
    Pour information, je me suis fait un peu allumé par @thevinz sur tindie parce que je ne lui ai pas répondu dans les 2 jours ouvrés
    Ce qui n'est pas mentionné, c'est que je lui ai remboursé son dongle, il me l'a retourné et je lui en ai gracieusement envoyé un nouveau modifié (pour tester sur le linky). Je devais avoir un retour de tests mais je n'ai jamais su si celui-ci fonctionnait.
    Enfin tout ça pour dire que le dongle fonctionne très bien sur les Linky. La bienséance aurait voulue que ce soit mentionné ici ou sur Tindie par le plaignant.



  • @charles
    La gentillesse et les gestes commerciaux ne sont pas toujours estimés à leur juste valeur :-(
    De plus, c'est très compliqué de réaliser des tests à distance, sans avoir la main sur le code et le matériel.

    Il faudrait voir aussi sur la Remora, car n'ayant pas de compteur Linky, il m'est difficile de réaliser des tests.

    @David
    Le xPL pourrait aussi m'intéresser, donc moi aussi je veux bien voir le code source, enfin si tu veux bien partager.



  • Bonjour charles,

    je vous ai commandé 2 dongles µTeleinfo et en attendant de les recevoir (ça ne devrait pas tarder ;-) ), je commence à configurer mon rpi 3 installé en Raspbian GNU/Linux 9.
    je me suis inspiré de la page http://hallard.me/teleinfo-emoncms/
    Seulement, sur sudo apt-get install git-core libmysqlclient-dev libcurl4-openssl-dev , j'ai une erreur ...
    Package libmysqlclient-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it: mysql-server-5.5

    Désolé si ma question est bête ... mais j'installe comment ?
    par avance, merci de votre aide


  • Staff

    Bonjour,

    Pouvez-vous éssayer
    apt-get install default-libmysqlclient-dev
    L'article est assez ancien c'est vrai.
    En revanche avec un PI3 et pour pousser sur emoncms, j'utiliserai plutôt NodeRED, très souple et facile de modifier le flux en live
    cf ce post



  • @charles
    ok merci de votre réponse super rapide, je vais essayer.
    Mon but étant d'envoyer les valeurs à intervalle régulier sur mon eedomus ou jeedom vai une requête http..

    edit : nickel installation faite, j'attends plus que le facteur ;-)


  • Staff

    La commande est parti le 18/09, les joies de la lettre verte, j'ai vu une fois une lettre verte mettre 2 semaines pour arriver, incroyable !!!!



  • Commande partie le 25, colis reçu le 27... déjà c'est mieux qu'amazon (en tout cas dans mon bled).
    Bravo @charles pour la rapidité, et surtout la qualité: je passe d'une trame correcte de temps en temps à 100% de trames correctes. Bref, génial. (pi3/compteur pas linky ;)



Looks like your connection to Community Forum was lost, please wait while we try to reconnect.