Problème Remora avec Particle Photon



  • Bonjour,

    J'ai réalisé la version 1.2c du matériel avec un photon, mais le photon a l'air de se planter avant même d'entrer dans la "loop" principale.
    L'écran s'allume mais il est brouillé. Est-ce que vous avez déjà eu ce cas ?0_1448296964772_IMG_0062.JPG


  • Staff

    @smillier
    ton OLED semble être un 1.3" et ceux-ci ont un contôleur SH1306 qui est différent du classique SSD1306.
    Le SH1306 n'est pas supporté pour le moment sur Remora.

    Peux commenter la ligne suivante dans remora.h et essayer à nouveau sans le LCD connecté ?

    //#define MOD_OLED      /* Afficheur  */
    


  • J'ai déjà essayé en désactivant tous les modules, OLED, RF69, teleinfo, relais, etc... rien ne change. Même en démarrant le spark hors PCB, j'ai le même comportement. A la limite, le brouillage de l'écran est un détail, même s'il provient de la liste des composants initiale du projet.
    Je vois que le log s'arrête en plein milieu d'une chaine de caratères lorsque je suis en terminal série sur le photon... assez étrange.



  • Après avoir testé l'écran OLED sur un arduino, tu as raison, le driver de celui ci est un SH1106 qui fonctionne bien avec la librairie u8glib donc je verrai si je peux porter le code pour le supporter dès que j'ai le temps.
    Toutefois ça ne règle pas mon souci initial, le photon continue de planter, ci dessous, le serial monitor:
    0_1448375665864_Error.png


  • Staff

    @smillier
    je viens de tester avec un core, aucun soucis, j'ai plugué un photon et après la MAJ du firmware en 0.4.7 visiblement ça plante dans le setup.
    Donc le soucis apparait avec le nouveau firmware.
    Encore une fois je tiens à remercier tout particulièrement Particle !!!!!
    J'ai encore ouvert un ticket bien sur, parce que nous ne sommes pas les seuls !!
    En attendant, c'est Web IDE et au moment au moment de selectionner ton photon tu mets bien Firmware 0.4.5 et çà devrait marcher (je sais WebIde c'est galère)



  • Oui, autant le spark était pas trop mal, autant le particle je suis moins convaincu. Je vais attendre un peu de tes nouvelles parce que le WebIDE, ça me plait pas des masses. Ou alors je pars sur un NodeMCU, j'hésite.
    J'ai vu dans le code que tu avais un début de séquence d'initialisation pour l'OLED sh1106, mais apparement c'est pas concluant. Tu sais à peu près ce qu'il faut pour faire marcher cette écran ? Je vais essayer de faire le code.
    Je vais regarder aussi pour ajouter le support MQTT si possible.


  • Staff

    @smillier j'ai essayé de porter la u8glib mais j'ai capitulé, il faut mettre tous les fichiers dans le même dossier et donc changer chemin des includes, bref j'ai déjà galéré avec RadioHead je m'attarde plus avec particle !!!!

    Oui le SH1106 il faut changer un truc à l'init et des coordonnées dans le display il me semble. Mais je vais changer de lib pour utiliser la MicroLCD que j'ai déjà modifiée (ellle fonctionne sur une passerelle ULPNode avec Particle/Photon/NodeMCU et supporte les 2 display ;-) donc juste qq copier coller et adaptation.

    Si tu veux participer et l'intégrer ça pourrait être cool, je peux t'envoyer les fichiers du projet car il ne sont pas encore releasés mais tu t'y retrouvera facilement le code est semblable à celui du Remora ;-)



  • @Charles
    J'ai vite laissé tomber aussi avec la u8glib, trop lourd ;-)
    Je veux bien que tu m'envoies ça oui, je peux participer, je dis pas que ça va avancer vite, mais si je peux donner un coup de main, pas de souci.


  • Staff

    Envoyé en MP, t'inquiètes pas t'iras toujours plus vite que moi ;-)



  • @Charles
    Merci bcp ! Je vais voir ce que je peux faire.
    Tu vends pas des pcb pour l'adaptateur NodeMCU par hasard ? Sinon j'en commanderai chez OSH.


  • Staff

    Si c'est prévu nous en avons prévu quelques uns avec la commande groupée de Remora en cours.
    Vendue avec les 2 transistors et le NodeMCU. Passe en MP si tu veux plus d'infos.



  • @Charles
    ça marche, merci !



  • Et flute moi qui vient de commander mes pcb ...


  • Staff

    @Fab_33
    Tu as commandé des adaptateurs ?



  • @Charles
    NodeMCU flashé et fonctionnel avec le code remora_soft en moins de 15min, un bonheur comparé aux heures d'incompréhension avec le photon...
    Du coup, j'ai 2 pcb de la version 1.2 dont je me débarrasse si ça intéresse quelqu'un ;) Je passe à la 1.3.
    J'ai pas encore eu le temps de m'occuper du code pour l'écran SSH1106, mais je fais ça dès que possible.


  • Staff

    @smillier
    Ahhh, tu vois ça change la donne l'ESP8266 hein ;-)
    en revanche, si c'est des PCB V1.2, si des personnes sont intéressées il est possible d'y mettre de l'ESP 8266 dessus grace à l'adaptateur dédié ;-)



  • Tout à fait, les v1.2 sont compatibles avec l'ESP, c'est juste que je vais partir sur la dernière version.



  • Avec la version 1.3 du PCB, il faut l'adaptateur aussi, non ?


  • Staff

    @Fab_33
    Oui avec la V1.3 il faut juste l'adaptateur, pour les V1.2 il faut l'adaptateur mais y souder dessus les 2 transistors ainsi que la resistance.



  • C'est ça. Donc si quelqu'un veut des pcb en v1.2, ne pas hésiter à me contacter.


Log in to reply
 

Looks like your connection to Community Forum was lost, please wait while we try to reconnect.