uteleinfo v2.0 trame illisible



  • Bonjour, j'ai acheté le module telinfo v2 et je récupére des trames illisible. J'ai essayé de reprogrammer completement le firmware comme indiqué sur github mais idem. J'ai un compteur linky avec le tic en mode standard. J'ai aussi essayé en direct sur le compteur.
    Peut être le module et HS. Pourriez-vous m'aider ?
    Le début des trames récupérées semble bon mais c'est la suite qui est illisible :

    picocom -b 1200 -d 7 -p e -f n /dev/ttyUSB0

    picocom v1.7

    port is : /dev/ttyUSB0
    flowcontrol : none
    baudrate is : 1200
    parity is : even
    databits are : 7
    escape is : C-a
    local echo is : no
    noinit is : no
    noreset is : no
    nolock is : no
    send_cmd is : sz -vv
    receive_cmd is : rz -vv
    imap is :
    omap is :
    emap is : crcrlf,delbs,

    Terminal ready

    FQK#BJZ@BPv** jB$e@(
    B@J@

                        *
                         JP+ (@@JDBRBkBB2
                                         P A 
                                             P HBJJv'@jB#JJG@
                                                             @B %
                                                                 RB@PB.jH`EF,RB"b+B$B*
                                                                                      $ @f!RB
    

    ./ftx_prog --dump

    ftx_prog: version 0.1
    InvRX = False
    Serial= TINFO-1001
    CBUS1 = PWREN
    CBUS2 = TxLED
    No change from existing eeprom contents.

    Le firmware sur github est-il le bon pour linky ?



  • @Julien-Chavant La vitesse en mode Standard est 9600 bps et pas 1200, ton problème viens de là. Change ta configuration : picocom -b 9600 -d 7 -p e -f n /dev/ttyUSB0



  • @Julien Chavant bonjour, je rencontre un problème similaire au votre avec le uteleinfo v2.0, je suis en mode standard sur un linky et les trames sont illisibles sur la sortie /dev/ttyUSB0
    Avez-vous réussis à fixer le problème?



  • Bonjour,

    Certains linky en mode standard nécessitent le changement d'une résistance comme indiqué ici

    https://community.ch2i.eu/topic/37/pitinfo-téléinfo-emoncms-avec-node-red-sur-raspberry-pi-moins-de-30-min-moins-de-10/19


Log in to reply