PITinfo v1.3 - aucune donnée sur le port série



  • Bonjour,

    J'ai reçu le PITinfo v1.3, et j'ai suivi les informations sur cette page :
    https://hallard.me/pitinfov12/

    La led fonctionne bien et répond aux commandes gpio. Elle est allumée de manière fixe.(est-ce normal ?)

    J'ai configuré le port série via raspi-config sur mon rpi zero w et mon /boot/config.txt contient ces deux lignes :

    enable_uart=1
    dtoverlay=disable-bt
    

    Malgrés cela je n'obtiens aucune info en faisant cette commande (en 1200 ou 9600 le résultat est identique) :

    pi@raspberrypi:~ $ picocom -b 1200 -d 7 -p e -f n /dev/ttyAMA0
    picocom v3.1
    
    port is        : /dev/ttyAMA0
    flowcontrol    : none
    baudrate is    : 1200
    parity is      : even
    databits are   : 7
    stopbits are   : 1
    escape is      : C-a
    local echo is  : no
    noinit is      : no
    noreset is     : no
    hangup is      : no
    nolock is      : no
    send_cmd is    : sz -vv
    receive_cmd is : rz -vv -E
    imap is        : 
    omap is        : 
    emap is        : crcrlf,delbs,
    logfile is     : none
    initstring     : none
    exit_after is  : not set
    exit is        : no
    
    Type [C-a] [C-h] to see available commands
    Terminal ready
    <<< RIEN ICI
    

    Aves-vous une idée de la raison ?



  • Bonjour,

    tu as bien désactivé le login shell via la serial dans raspi-config ?

    Dans l'article que tu mentionnes, concernant la désactivation du bluetooth, il est indiqué que la procédure est dans l’article suivant Enable Serial on Raspberry PI dans la section “Serial has changed with Raspberry PI Version 3”

    Or dans ce dernier, la commande dt-overlay est différente de celle que tu mentionnes :-)

    dtoverlay=pi3-disable-bt
    


  • @Charles said in PITinfo v1.3 - aucune donnée sur le port série:

    Enable Serial on Raspberry PI

    Oui j'ai désactivé le login shell via raspi-config.

    J'avais en effet à force de chercher la cause viré "pi3-" en pensant que ça serait lié au modèle mais ça n'a rien changé.

    Depuis j'ai bien remis pi3-disable-bt et je ne vois toujours rien remonter.

    Est-il possible que le Linky n'envoie rien du tout ?



  • Trouvé le problème aujourd'hui, apparement ça vient du câble que j'utilisais entre le compteur et le PITinfo.

    A n'y rien comprendre, mais j'avais démonté le Pi zero et relié les RX et TX pour faire un test du port série en loopback et c'était OK, j'en ai donc déduit que c'était soit le PITinfo, soit le câble, soit le compteur.

    J'ai commencé par tester le câble en le remplaçant par un autre et ça marche nickel.


Log in to reply