ESP8266 Reset and CH_PD pins for FTDI auto reset

  • @phermansson
    no you won't, you can remove D1 and D2 but need to leave D5

  • Hi! this is cool :)
    Some questions:
    I'm using a similar design with a CP2102 which only has DTR, and operates at 3.3V.

    • You say that in this case D1 and D2 can be removed, I assume these are the same in the first and second diagram? (they are not numbered in the second diagram :) ).
    • Is the reason to use Schottky (only) the low forward voltage? I only have some 1N4148, using one for D5 seems to work, using it for D1 and D5 does not for some reason :)
    • The B5819W would be the same as 1N5819 I assume? Might order some, do you think it's a good common Schottky to have? :)
    • How do you make this work in software??? Setting DTR on, then off, does put it in flash mode, and Arduino software in NodeMCU mode does manage to flash correctly. But Arduino Serial monitor seems to set the DTR wrong, then it stays stuck in flash mode :)

  • Yes they are the same diodes on the 2nd diagram. I think it should works with 1N4148, tell me if it's the case, I'd like to know. And yes Schottky to avoid approx 0.6v dropout voltage, just that.

    On software, view, I just set in Arduino IDE NodeMCU board and all id then fine (ck reset type as far as I remember), that's all ;-)

  • Well, I've something that works good enough for me now :)

    • With a CP2102 (3.3v) just 1 1N4148 for D5 seems to work (removing D1 and D2). For safety I put a 470 ohm in series with D5. This is using the CH_PD diagram.
    • Uploading works like this with stock Arduino (Actually I have it set on NodeMcu mode).
    • But serial monitor messes it up, so instead I use non stock Arduino IDE from: it disables serial monitor messing with DTR/RTS :).

  • Can not get this to work on a ESP12F at 3.3V. I am using the 'ch340' USB>TTL and there is a DTR and RTS on it. AI Thinker default firmware works so its talking to the adapter. I have removed the D1 and D2. I only have '4148' diodes. I'm suspecting the 100nF capacitor might not be enough. I don't own an oscilloscope, maybe my logic analyzer could tell me something.
    12K pull-ups.

    Here is my project

  • Aha. The issue from my previous comment was because the ch340 documentation had different package than what i have on my adapter. 20 pins Vs. 16 pins.

  • I tried it today and it works. Only used the diode that connects to gpio0 and the capacitor. I didn't used the other 2 diodes. The diode I used is a regular 1N4002. It doesn't work everytime, because sometimes it gives me the "espcomm_upload_mem failed" but it gave me that error before when I used the buttons method and I could see clearly that the ESP8266 is in flash mode in serial command window. So this circuit is not the problem of that error.
    Thank you Charles!

  • Hi,

    I'm using a 3v3 only variant of this circuit but that should not be a factor.

    Noticed a lot of issues with (some) modules (on some board designs) not entering or randomly not entering programming mode to various degrees. After some prodding I ended up increasing the size of the 100nF cap to 10uf and all problems disappeared over all the modules I'm using. Seems that startup timing can change between modules. My reference schematic here : from 2019-01-13 16-52-00.png?dl=0

  • Oh, also forgot to mention, have also observed problems with schottky's with larger reverse leakage currents, the BAT48Zfilm works where these other diodes don't, haven't had time to nail down precisely why yet as the alternates had a lower voltage drop, only other difference was larger reverse leakage current.

  • Sadly I could not get it working. Tried different Elkos and Kerkos and used a SS16.