PiTInfo V1.2, en finir avec la téléinfo capricieuse



  • Bonjour,

    J'ai commandé un module Pitinfo et je l'ai bien reçu. J'ai un soucis pour le faire fonctionner. Ma configuration est la suivante:

    • Un RPi B+ avec le logiciel itow, 3 sticks USB teleinfo et 1 stick 1-wire
    • Un RP1 2 B avec le logiciel jeedom et le module Pitinfo

    Mon but est d'avoir mon compteur principal branché en même temps sur un stick USB du Pi B+ itow et sur le Pitinfo du RPi2 jeedom. La partie itow (Pi B+) fonctionne sans problème depuis plusieurs années. Quand je branche en même temps le compteur principal sur le Pitinfo, c'est comme si plus rien ne fonctionnait et le perd complètement la teleinfo sur les 2...

    Est-ce qu'il y a un problème particulier a brancher la même sortie teleinfo sur 2 récepteurs ?

    Merci d'avance pour votre aide.

    Alex



  • @lelex79
    brancher deux appareils sur la même sortie ne se fait pas n'importe comment. Il faut que chacun des appareils respecte les spécifications EDF, et le type de branchement est important (parallèle, je crois). @Charles a évoqué rapidement la compatibilité avec d'autres appareils sur cette page: https://hallard.me/pitinfov12/



  • @Lelex79,

    Oui le montage PiTelinfo depuis la V1.2 respecte la norme ErDF depuis l'ajout du MOSFET mais ce n'est pas forcement le cas sur Micro Téléinfo puisqu'il a été conçu à la base sur le schéma à base d'opto trouvé sur le net.
    Mais la version 1.1 corrigeant le soucis sera dispo très bientôt ;-)

    0_1455529594476_micto-teleinfo-V1.1.jpg

    Commme le dit @mjeanne il faut les brancher en //, ceci dit, pour info chez moi 2 micro teleinfo branchés en // ne posent aucun soucis, comme quoi.



  • Merci @Charles et @mjeanne pour vos réponse. Je vais donc attendre la nouvelle version 1.1 du micro teleinfo :) Vu que le PiTeleinfo est déjà compatible, avec les 2 ensemble connecté en // sur mon compteur cela devrait marcher.

    A++

    lelex79



  • @lelex79
    Il me reste 2 prototypes parfaitement fonctionnels, passe en MP si tu veux plus d'info.



  • @Charles, je n'ai pas trouvé la fonction MP mais je t'ai envoyé un chat. Je suis très intéressé par un de tes prototype fonctionnel. Tu peux me répondre sur le chat si c'est OK pour toi.



  • Bonjour,

    Avec l'aide de ces super tuto et des personnes qui ont pris le temps de me répondre j'ai enfin réussi à réaliser mon petit projet.

    J'ai maintenant mon système itow qui tourne sur un Rpi 2B avec:

    • 2 sticks USB teleinfo que j'avais deja
    • 1 stick teleinfo de µTeleinfo (pour mon compteur general)
    • 1 stick USB 1 wire

    J'ai un second Rpi B+ ave:

    • 1 module PiTinfo v1.2 (aussi branché sur mon compteur général) et Node-red d'installé

    J'arrive à faire fonctionner sans problème la teleinfo de mon compteur général sur les 2 modules en même temps et j'utilise Nore-red pour remonter les infos vers Jeedom. C'est plus ludique que d'utiliser un jeedom slave je trouve car cela me permet de comprendre le décodage des trames teleinfo et la lecture du port série.

    En tout cas un grand merci à @Charles pour ce site et toutes ces infos.

    A++

    Lelex79



  • Bon je reviens (encore, désolé) avec quelques questions en plus ... mon système fonctionne mais j'ai noté que si je redémarre le RPi avec Node-red il ne récupère pas le signal téléinfo. Je dois débrancher la liaison téléinfo (donc les 2 modules) et les rebrancher en même temps. Est-ce que cela vous semble normal ??



  • @lelex79
    ouais pour faire démarrer node-red au démarrage je galère à chaque fois mais maintenant avec la dernière version Debian jessie pour RPI le pb est réglé (j'ai validé ya 2 jours). Tout est ici
    Sinon peut être que l'affectation des ports (/dev/ttyUSBx) changent à chaque boot, il faut les régler comme expliqué dans le tuto



  • @Charles, effectivement j'étais tombé via mon ami big G sur ce même site et j'ai résolu mes problèmes de démarrage de Node-Red.

    Par contre pour le problème qui persiste cela ne peut pas venir de l'affectation des ports USB car le problème survient uniquement sur la machine qui a l'interface serial. En résumé le symptôme est:

    • au démarrage des 2 RPi, tout se passe bien mais le teleinfo ne remonte que vers celui qui a le stick USB (c'est aussi celui qui boot le plus vite car c'est un RPi2). Le PiTinfo serial ne reçoit pas de données.

    Et pour résoudre ce problème:

    • je débranche les fils teleinfos du compteur quelques secondes et je les rebranche et là la teleinfo arrive sur les 2 interfaces.

    En fait c'est un peu comme si le PiTinfo n’était pas capable de détecter les trame si un autre module les reçoit déjà. Par contre si les 2 modules commencent a les recevoir en même temps c'est OK.

    Je vais faire encore quelques tests ce week-end mais si ce problème est persistant je pense mettre simplement un petit contacteur sur ma sortie teleinfo. Ainsi si mon système domotique détecte qu'il n'y a plus de remontée vie le module serial PiTinfo, il actionne le contacteur pour déconnecter la teleinfo, attend 5 secondes et la reconnecte.



  • Bonjour,
    Merci pour le partage et le travail!
    J'ai pris le fichier 1.2.brd sur github, cependant il n'est pas accecpté par OSH Park, connaissez vous le probleme?
    Merci de votre aide
    Nicolas



  • J'ai trouvé, l'entête du fichier est modifié quand on telecharge directement avec le liens.



  • Bonjour @Charles,

    Je suis en train de faire un autre flow Node-Red sur le même RPI que celui sur lequel est branché le module PiTinfo. Pour ce second montage j'aurais besoin de récupérer le 5V du RPi hors la broche 5V est branché sur le module PiTinfo. Je comptais donc souder un fil directement sur la carte PiTinfo pour récupérer. Est-ce que tu vois une contre indication quelconque à cela ? D’après les schéma technique le 5V ne semble pas utiliser mais je préfère m'en assurer avant de faire n'importe quoi :)



  • @lelex79
    Aucun soucis tu peux récupérer le 5V dessus ;-)



  • Bonjour,
    Merci et félicitations pour ce travail. J'ai commandé la carte que j'ai reçu très rapidement. Aucun soucis pour la connecter à un nanoPi neo et récupérer les infos du linky. Par ailleurs, je projette de l'intégrer proprement et sans fil avec une carte à base d'ESP8266 et je souhaiterai savoir s'il serait possible d'alimenter le montage directement depuis le linky? D'après la doc, le linky possède 3 sorties au niveau de la TIC (I1, I2, A) dont une alimentation disponible entre I1 et A dédiée à ce scénario. Avez-vous déjà tenté l’expérience sachant que les caractéristiques de cette alimentation me paraissent étrange (6Vrms à 50 KHz) ? Je ne suis pas expert en électronique mais j'imagine qu'un pont de diodes et un condo s'imposent ?
    Merci d'avance si vous avez des infos ;)



  • Bonjour
    J’ai reçu le module PiTinfo V1.2 monté sur Raspberry pi3.
    Je ne parviens pas à afficher les données Téléinfo.

    • J’ai paramétré le port série du Raspberry pi3.(Sudo rasp1-config)
    • Le test de la led est ok.
    • Mon compteur EDF n’est pas un lynky.
    • J’ai tester une inversion de connexion des bornes du compteur i1-i2
    • L’ option Téléinfo devrait être fonctionnelle car j’avais un module Dauguet qui a fonctionné il y a 2 ou 3 ans.

    question de béotien , le module est bien alimenté par le Raspberry ?
    J’ai vu sur le forum qu’on pouvait shunter R3...
    Franck



  • Bonjour Franck
    Oui le module est est bien alimenté par le PI. Tu as acheté ton module récemment ? Car depuis qq mois plus besoin de shunter R3 c'est une 1.2K et plus 4.7K



  • Bonjour Charles,
    J’ai acheté le module il y a 3 semaines.
    Je ne parviens tjrs pas à voir une trame d’information de mon compteur.
    J’étais abs la semaine dernière pour raison et j’ai lâché l’affaire.

    J’avais essayé de voir les informations en consultant un autre site traitant de feleinfo(journaldulapin.com)

    Première chose, mettre à jour l’OS.
    sudo apt-get update
    sudo apt-get upgrade

    Ensuite, lancez un raspi-config et désactivez la console série dans les options. Il est aussi nécessaire de bien fixer la date (et le lieu) pour être certain d’être à l’heure.

    sudo raspi-config

    Enfin, une petite modification est nécessaire pour lire correctement les données téléinfo.

    sudo nano /etc/rc.local

    Dans le fichier, juste avant exit 0, il faut ajouter la ligne suivante.
    stty -F /dev/ttyAMA0 1200 sane evenp parenb cs7 -crtscts

    Rien ne fonctionne et je ne sais tourjours par quel bout prendre le problème
    Pb de param Raspberry pi3?
    Mon signal Téléinfo
    Le module pitinfo?

    Franck



  • Franck,
    As tu bien réalisé la modif dédié au PI3 concernant le port série pour le remapper sur l'AMA0? Voir section Serial has changed with Raspberry PI Version 3

    Pour moi la modif dans le rc.local sert à configurer par défaut le port série, je ne le fait jamais car tu sais jamais qui fait quoi avec après
    Je préfère le configurer avec l'outil de lecture, d'ailleurs tu n'indiques pas avec quelle commande tu essais de lire les informations (script, logiciel, service, ...) donc pas évident de t'aider

    En revanche la façon de tester le module a été expliquée plusieurs fois sur le forum, dont une
    ici avec 2 méthodes différentes (privilégie la méthode picocom).



  • Bonjour
    Merci. Pour la réponse.
    Je vais essayer de revoir cette configuration du port série.
    Pas simple quand on est pas une spécialiste

    Franck


Log in to reply