Problème Teleinfo sur Jeedom avec montage "classique



  • Bonjour à tous,

    Novice dans la domotique (depuis juillet 19), je viens de m'attaquer à la remontée de la téléinfo sur ma jeedom smart afin de compléter ma solution de pilotage de mon ballon d'eau chaude (j'ai déjà mis la sonde de température dans le ballon qui remonte sur jeedom via un raspberry PI3).
    J'ai fait la partie électronique en suivant le schéma de Charles, avec cette liste de course :
    -optocoupleur LTV814
    -mosfet N BS170
    -2 résistances de 10 kohms
    -1 résistance de 4.7 kohms

    Mais je n'arrive pas à avoir de remontée des infos téléinfo, il n'y a rien dans l'onglet "données de téléinformation". J'ai plusieurs pistes d'erreur mais je sèche pour résoudre le problème et j'ai besoin de vos lumières :-)

    -1ère piste : dans l'interface du wifinfo, lorsque je mets le paramètre Jeedom/Mise à jour = "toutes les 15secondes", j'ai le Uptime qui ne dépasse pas 15secondes. Alors que quand je mets le paramètre à "désactivé", le Uptime progresse sans s'arrêter. J'avais compris que le paramètre "Mise à jour" servait à envoyer les données à Jeedom, est ce que je me trompe? Du coup si le Uptime s'arrête à 15secondes, cela signifie que le NodeMCU s'arrête toutes les 15 secondes?
    Wifinfo_Paramètre_Mise-a-jour.JPG

    -2ème piste : actuellement, ma téléinfo est utilisée par un module Legrand qui fait la gestion des HC-HP, du délestage et des zones de chauffage électrique. J'ai donc débranché les 2 fils du module pour les rebrancher sur mon NodeMCU. Mais j'ai environ 15m de cables de 1.5mm² entre le compteur et mon NodeMCU pour faire transiter les infos de la téléinfo). Est ce trop long?

    -3ème piste : j'ai utilisé un MOSFET N BS170 sur ma platine, mais j'ai un gros doute sur le sens de câblage des 3 pattes... J'ai trouvé ce schéma du BS170, est ce bien la patte 3 (source) qui va sur la pin Ground du NodeMCU?
    mosfet.JPG

    Merci de votre aide.



  • Piste 1, la config n'est pas bonne. Comme indiqué ici, le plugin n'accepte plus les requêtes en GET. Il faut utiliser le script GWTeleinfo.php comme intermédiaire. Et du coup dans URL il faudra mettre /GWTeleinfo.php

    Piste 2, oui ça paraît très long. Pas moyen de tester plus proche ? Et puis ça paraît très bizarre de mettre du 1.5mm² pour de la téléinformation. T'es sur quelles bornes du compteur électrique ? Certain de ne pas être sur le contact HP/HC ?
    Une fois validé le fonctionnement, un câble blindé avec paire torsadé pourrait aider. Tu peux utiliser un câble ethernet, c'est pas très cher.

    Piste 3, t'es parti sur quel schéma ? Celui sur cette page ? A priori je dirais que c'est bon oui. Au pire tu le retournes pour essayer. Par contre, t'as un compteur Linky ou pas ? Parce qu'avec le Linky, certains ont été obligés de changer une résistance, en abaissant la valeur de celle de 4,7k.


Log in to reply