problème de compilation pour remora 1.0



  • Bonjour à tous

    Je possède un remora version 1.0 avec un spark core
    J’essaye de flasher la version 1.3.4 de remora.h télécharger depuis Github
    Auparavant, j’ai modifié #define REMORA_BOARD_V10 // Version 1.0 afin d’avoir la version compatible avec mon hardware puis j’ai mis en commentaire la ligne de version de default .
    Voici le fichier modifier

    L’IDE de particle desktop renvoi les erreurs tels que :
    -Expected initializer before ‘PROGMEN’

    Je cherche mais j’ai toujours ces erreurs des compilation.
    Avez-vous une idée ?
    merci d'avance pour votre aide
    Gabriel



  • Bonjour, personne n'a vraiment d'idée ?



  • bonjour UP



  • Bonjour @gabriel

    La version 1.0 est maintenant très loin derrière nous et je n'utilise, ni n'assure le code pour le Spark Core. D'ailleurs, il y a déjà bien longtemps que l'on aurait dû supprimer les parties du Spark.
    As-tu déjà commencé par compiler le code avant même de le modifier, rien que pour vérifier qu'il compilait correctement ?

    Manuel



  • Bonjour merci pour votre reponse je viens d'essayer et oui effectivement avec la configuratoin de default il me retourne les erreurs suivante0_1544533925466_2018-12-11_14h10_41.png 0_1544533933271_2018-12-11_14h11_20.png