PiTInfo : Téléinfo, Emoncms avec Node Red sur Raspberry PI, moins de 30 min, moins de 10€



  • Bonjour
    j'ai le Micro Teleinfo V2.0 avec un raspi zero avec node-red en version 0.20.5
    J'ai rencontré la même erreur que Erwan :

    "TypeError [ERR_INVALID_ARG_TYPE]: The "size" argument must be of type number. Received type object"
    

    node-red-node-serialport en version 0.8.1 semble avoir un peu changé, il faut mettre (0x03) pour ne plus avoir cette erreur.
    On reçoit alors bien un flux de donnée mais il n'est pas correctement "coupé" comme si le caractère 0x03 n'était pas toujours détecté. Dans la partie droite de la capture on voit que les données reçu sont plus ou moins longue
    Capture2.PNG

    j'utilise /dev/ttyUSB0, je ne sais pas si ça peut être la cause du problème.
    Avant d'utiliser le raspi j'utilisais Micro Teleinfo V2.0 sur un PC avec ubuntu, node-red en v0.19.5 et node-red-node-serialport en v0.6.8 sans aucun problème.

    Le problème pourrait t'il venir d'une erreur de conf du port serial USB ? je n'ai pas tous compris avec /dev/ttyAM0 et UART...
    Ou alors le problème serait plutôt dans une évolution de node-red-node-serialport ?



  • @Charles merci.
    Peux tu envoyer une photo ?
    J'ai trouvé une vieille manip ou tu ajoutes un 10K pour un pullup....mais je ne crois pas quon parle de la meme chose. merci.
    https://community.ch2i.eu/topic/217/fix-problème-de-réception-µtéléinfo-v1-1
    edit : j'ai fini par trouver les 2 plans, mais j'hésite à allumer le fer à souder .....



  • Salut c’est Erwan, j’ai exposé mon problème plus haut…
    J’ai trouvé ma réponse tout seul, node-red (je ne sais pourquoi) n’accepte pas 0x003 ou 0x03 comme caractère de “coupure”
    J’ai trouvé quelque part la commande:

    picocom -b 1200 -d 7 -p e -f n /dev/ttyAMA0
    

    J’ai d’ailleurs été impressionné (peut-être sans raison par la simplicité/efficacité de ce petit programme.

    Ça me donne des petits caractères à la con entre chaque trame (la coupure si je ne me trompe pas) sélectionner/copier le premier des 2 caractères dans le terminal, copier dans node-red et magie… les trames sont parfaitement coupées au bon endroit.
    En fait ce n'est pas facile de sélectionner un seul caractère dans le terminal, j'en ai sélectionné plusieurs, coller dans un éditeur de texte, puis copier seulement le 1er caractère
    teleinfo.png

    J’espère que cela aura pu dépanner quelqu’un..
    Merci pour ce site. C'est chouette.



  • @Charles Bonjour,
    J'ai reçu 2 nouveaux pitinfo USB et ils ne decodent toujours pas le mode standard. Y a t'il une explication ?
    Merci. Julien.
    picocom3.png



  • @sunshare
    Arff, peux-tu essayer de changer R6 par une 4K7 ? ou souder une 10K par dessus ?

    f051b7f9-8607-4e2b-b8bf-c57e1134fc07-image.png

    Je peux t'envoyer les resistances CMS si tu veux?



  • Bonjour,

    Je viens de recevoir un Micro Teleinfo v2 fraichement commandé.
    Je suis très étonné que le problème en TIC standard soit toujours présent, et qu'il faille encore souder un resistance supplémentaire sur ce produit !
    @Charles vous ne comptez pas refaire une version ???



  • @davTIC
    La réponse est extrêmement simple, c'est tout simplement que le problème avec le mode standard est apparu après le batch de fabrication. Donc bien sur le prochain batch contiendra le fix adéquat.
    Qui plus est je n'ai toujours pas de Linky chez moi donc j'ai du tester tout ça en aveugle, heureusement que des utilisateurs de Linky ont aidé la communauté.



  • @Charles
    Bonjour,
    Je viens de mettre une résistance de 4.7k en R6, mais quand j'entre la commande :

    picocom -b 9600 -d 7 -p e -f n /dev/ttyUSB0
    

    j'ai le résultat suivant :

    picocom v3.1
    
    port is        : /dev/ttyUSB0
    flowcontrol    : none
    baudrate is    : 9600
    parity is      : even
    databits are   : 7
    stopbits are   : 1
    escape is      : C-a
    local echo is  : no
    noinit is      : no
    noreset is     : no
    hangup is      : no
    nolock is      : no
    send_cmd is    : sz -vv
    receive_cmd is : rz -vv -E
    imap is        : 
    omap is        : 
    emap is        : crcrlf,delbs,
    logfile is     : none
    initstring     : none
    exit_after is  : not set
    exit is        : no
    
    Type [C-a] [C-h] to see available commands
    Terminal ready
    0
    EAST	000000000      @0000000000	$      00	000000000	#
    AASF03	000000000	$
    EASF04	000000000	%
    EASF05	000000000
                   0000000000	'      A07	000000000	(      AASF08	000000000	)
    EASF09	000000000	*
    EASF10	000000000
                   EA0000000000	$	
                                            EA0000000000	!      03	00000000S@04	000000000	#
    AAIT	003801290	\
    ERQ1	000000000	;
                            ERQ2	000008200
    
                                            P000209118	       4	00000003MS1	231	D
    PREF	02	A
    PCOUP	02	[
    SINSPS	00000	F
    SMAXSN	E200615062024	00080
                                SM
    SINSPI  01005   B            000410010438	00181	W
    SIAXIN	E200615135309	02260
    
                               SMAXI
    ASN     E200611180000   00000  0/0400143033	00439	I
    CCASN-1	E2006151600000000	
                                  	200411183000	01000	!
    CCAIN)1	E200615180000	01180	
    
                                   UMOY1	E000404082000	031	/      G	0030301	9	1	PAS DA          MESSAGE     8
                                                        PR04862080403080	7     L000	@	
                   	01	N
    U	00	&
    URF+1	00	B
    PJOURF+1	00008001 NONUTILE NO
                                       L
    
                                        	
                                            E 
    
                                              PILA NONQTILE NONUTILE NONUTILE 
    
    
    
    
                                                                                   
                                                                                   O02094137A200611183724	J       E
    NGPF	   PRODUCTEUR   	.
    LTARF	IND
    
               N
    01      000000000	&
    AASF02	000000000	#
    AASF03000000000	$
    EASF04	000000000	
    07      000000000      E(SF05	00000000$      0000000000	'
    AASF08	000000000	)
    EASF09	000000000	*
    EASF10	000000000
                   0000000000	 
    00	000000000	!	
                                    AAS@03	000000000	"
    EASD04	000000000	#
    EAIT	003801280
    
    ARQ40193000000038RQ00000I000	;
    IRMS1	004	2
    URMS1	235	D
    PREF	02	A
    PCOUP	02	[
    SINSTS	00000	F
    SMAXSN	E200404040000	00095	0	
                                            )1	A200610210638	00185	W
    SINSTI	01007	D
    SMAXIN	E2006140202000040	)	
                                            )1	000614103233	02439	M
    
    	00041518000000000	/
    CCASN-1	E200615170000	00000
                              CC000400183000	01000	)	
                                                                    	L)1	A200611180000	01180	M
    0020301	92006111           MESSAGE         	<
    PRM	25973080002086
    
                        000		
                                  01	
    
    T	00	$
    OF+1	00008001 NONUTILE NONUTILE N
    

    Voici la modif que j'ai faite :

    Pit-V2.0_avec_R6_4.7K.jpg

    Que dois-je faire?
    Merci de ton aide



  • Bonjour,

    Wahou quel challenge de souder une 4K7 comme ça, félicitations :-)
    Tu peux me faire une photo de R3, normalement le silk indique 4K7 mais ce doit être une 1.2K de soudée non ?



  • Pas facile en effet !!! C'était ma première soudure de cette taille.
    A priori tu as raison c'est une 1.2K, enfin je pense.
    Voici la photo:
    Pit-V2.0_avec_R3_1.2K.jpg
    Que puis-je faire d'autre?
    Eric



  • @Charles
    As-tu de bonnes nouvelles pour moi ?



  • Eric,

    Franchement je ne sais quoi te dire, tous ceux qui ont fait la modif ça fonctionne. Et je n'ai as le Linky pour vérifier.

    Peut être remplacer la 4K7 par une 3.3K ou 2.2K pour tester?



  • Eric, je viens d'avoir un retour d'un utilisateur qui a le même problème que toi, il a mis une 1K en lieu et place d'une 4K7, ça semble fonctionner impeccable à 9600 bauds